Turbo Buick Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter · #1 ·
So at what mileage did you replace yours?
 

·
Registered
Joined
·
683 Posts
My engine only had 7K miles on it and the stock spring pressures were all over the place! I like the Comp Cam springs and they test good after using them for several miles. (they hold the original pressures after use better) The worst springs out there are the LT1 GM springs. (pressures were all over the place brand new, GM junk) I tested several vendor's springs and they tested pretty close in pressures, brand new! Gene

<small>[ June 22, 2003, 03:24 AM: Message edited by: ILBCNU6 ]</small>
 

·
Registered
Joined
·
6,966 Posts
112K and 123K two cars.

Would have changed them sooner if I was smarter.

Stockers on both cars tested at 58-66 or so.

Real bad.
 

·
Resident Idiot
Joined
·
11,462 Posts
I replaced mine around 105k. I replaced them with the 'club springs' from GSCA. Didn't really notice a difference in performance and didn't mess up my stock cam so I was just happy with the peace of mind that I wasn't going to be floating valves in the future. usa
 

·
Registered
Joined
·
6 Posts
Father had his done recently.
Car had 55,000 miles. picked up 11RWHP with just the valve springs.
 

·
I want a Z06
Joined
·
6,024 Posts
Did mine at 90K.

Every Buick Needs springs if your still running stock ones. yup
 

·
Dr. Theopolis
Joined
·
783 Posts
Had mine done at about 120k. It was not pulling at the higher rpm range.

Scott
 

·
Registered
Joined
·
243 Posts
okc87GN:
What was the Comp Cam spring Part Number That you used? Was this for stock Cam? Thanks
249-980-16
 

·
Registered
Joined
·
225 Posts
Discussion Starter · #11 ·
well my car has 63000 now. And at the top end it doesn't feel like it wants to pull any harder. I plan to put the comp cam 980's soon.
 
1 - 11 of 11 Posts
Top