Turbo Buick Forums banner
1 - 4 of 4 Posts

·
aka: mOtOrHeAd MiKe
Joined
·
6,603 Posts
Discussion Starter · #1 ·
This sounds really odd... but I got back from the track last night, and when I got off the highway I noticed something funny when slightly off idle: a ticking/rasping @ ~1200rpm. Torque converter bolts? Exhaust leak? Headgasket?

Hmm... got the car home. Broke the turbolink back out... went for a drive and found that most everything is just where it is supposed to be, ideal conditions if you will.

Popping the hood and feathering the throttle it sounds like the rocker arms are ticking. Is it abnormal for the shafts to loosen off? There are only 3 bolts holding them in place afterall.

Doing the basic over lookage this morning:
Plugs: perfect leanish/clean burn
Coolant: all there
Oil: no coolant in it

Any thoughts?

Thanks,



------------------
Michael Lis

87 Vortec SS -- 12.7 @ 110 w/ 1.9 60' (This car runs 12s on 87 octane)
Click Here To See Specs
87 Turbo T - 1986.99 WE4 Clone -- 13.4 @ 101.1mph w/2.0 60'
Click Here To See Specs
See the cars here:
Canadian Skunk Works

Originally posted by myclone
I see you have ODed on retardacylin today. Want me to call an ambulance?
 

·
Premium Member
Joined
·
43,735 Posts
It is not totally unusual on high mileage engines for the rocker shafts to wear and cause some knowledge...also not unusual for them to break.

Then there are exhaust leaks at the crossover, headers to heads, cracks, etc. plus the cam sensor, loose ic brackets, idler pulley hitting the ac compressor, etc....
 

·
aka: mOtOrHeAd MiKe
Joined
·
6,603 Posts
Discussion Starter · #3 ·
Originally posted by Steve Wood:
It is not totally unusual on high mileage engines for the rocker shafts to wear and cause some knowledge...also not unusual for them to break.

Then there are exhaust leaks at the crossover, headers to heads, cracks, etc. plus the cam sensor, loose ic brackets, idler pulley hitting the ac compressor, etc....
Well, I am hoping to get the VC off and take a peak inside. I can look at all of the other situations as well. My cam sensor has ticked since day 2, and even after a shimming.

Funny you mention loose I/C brackets... I lost the DS I/C bolt last night on the ride home. Need to get another... just gotta figure out the size.



------------------
Michael Lis

87 Vortec SS -- 12.7 @ 110 w/ 1.9 60' (This car runs 12s on 87 octane)
Click Here To See Specs
87 Turbo T - 1986.99 WE4 Clone -- 13.4 @ 101.1mph w/2.0 60'
Click Here To See Specs
See the cars here:
Canadian Skunk Works

Originally posted by myclone
I see you have ODed on retardacylin today. Want me to call an ambulance?
 

·
Registered
Joined
·
293 Posts
I lost an IC bracket bolt too and would appreciate the size also. I believe it has a 13mm head
 
1 - 4 of 4 Posts
Top