Turbo Buick Forums banner
1 - 5 of 5 Posts

·
Banned
Joined
·
32 Posts
Discussion Starter · #1 ·
I finally got to take my Regal out on the road on Sunday for its maiden voyage, basically a fault finding trip so i can keep improving it, but one thing has me stumped !

When driving (pretty slow and calmly) i get a load of shudder when the car shifts from 1-2, its fine the rest of the time, if i drive it harder, i get less shudder, almost as if its shuddering at a specific RPM. The sudder is like the pinion angles are screwed and its eating a UV joint !

I'm completely new to Auto box's having only ever had manuals so any advice would be great.

P.S its a bog stock 231 3.8 N/A bolted to whatever gearbox they put in those 1980 regals :dunno:
 

·
Banned
Joined
·
32 Posts
Discussion Starter · #2 ·
just incase anyone is interested i've had some advice to check the TCC? and the prop and joints, hopefully that'll fix it :)
 

·
trans tech
Joined
·
78 Posts
has anything been done to trans or t.v. cable adjustment? :dunno:
 

·
Banned
Joined
·
32 Posts
Discussion Starter · #4 ·
nope, the engine (less smog pump) and drivetrain are completely stock for now, i just need to get it running good before i start 'improving' it
 

·
Banned
Joined
·
32 Posts
Discussion Starter · #5 ·
problem solved, my adjustable top arms were too long (stock = 11" mine 12.5" and this was causing the uj angles to be running at their limit under load causing the rumbling and grinding ! :headbang:
 
1 - 5 of 5 Posts
Top