Turbo Buick Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,693 Posts
Discussion Starter · #1 ·
I am running rich and looking for other things to check.
Fuel pressure checked at 45 line off.
Vacuum at 15.
Pulled plugs and all were rich.
Running the thrasher but will change chips tomorrow.
Any other things to check for being rich?

TIA
ES
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
1,693 Posts
Discussion Starter · #3 ·
BLM were around 105 at idle. With the thrasher, they have always been 128.
Filter is new.
I know that the 105 is not out of range but I was wondering if something is not operating correctly because it has always been at the 128.

[This message has been edited by ES (edited November 22, 2001).]
 

·
Registered
Joined
·
703 Posts
Steve,

on rich conditions... what should we look for on the scanmaster??

Would O2 counts of +700 (every 1 or 2 times) at idle indicate rich condition??
 

·
Premium Member
Joined
·
43,735 Posts
No...I think it depends upon the chip but 700 might be slightly rich....I think I pay more attention to the blms....numbers below 128 indicate that the the ecm is pulling fuel out to correct what it perceives to be a rich condition and over 128 indicates it is adding fuel because it believes the car is lean and needs more fuel.

The above is for conventional chips. Normally we say +/- 10 from 128 is okay. 105 is still within range but indicates that the ecm is working hard to keep the mixture in check.

Remember that it may read one thing at idle and another thing at cruise.

ES, did you change chips? Is it running low numbers at cruise, idle, etc? YOu could try varying the fuel pressure and see what happens.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
284 Posts
The Thrasher chip is a little tough to fine tune with a blm problem. Thrasher locks the blm at 128 at idle, so you can only tell differences in blm during cruise.... Maybe try a different MAF if you can get ahold of one.

------------------

Best time so far: 12.78 at 107.5mph on radials, 2.05 60 ft
Car weight without driver 3610 lbs
 

·
Registered
Joined
·
1,693 Posts
Discussion Starter · #7 ·
The thrasher used to be 128 at idle but was showing the 105.
I will try different chip first.
Then I was going to try a new 02 first before trying a new MAF.
Am I off base on the 02?
No code errors.
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
1,693 Posts
Discussion Starter · #9 ·
It is going through the cc but not as fast as it used to.
When I start my car, it does not smoke and no condensation, but once it warms up and as soon as you hear the engine change, condensation starts coming out the pipes and the car smokes. There in no antifreeze in the condensation.
Am I correct to assume this condensation is from a rich condition?
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
1,693 Posts
Discussion Starter · #11 ·
At idle 4-5.
Steve, you would have to see this. It is a bunch of condensation!
All of this started when I added the SMC kit.
I think I am chasing 2 problems, a rich condition and a smoke (oil) condition.
I can only handle 1 problem at a time!
 

·
Premium Member
Joined
·
43,735 Posts
Your bottle is mounted below the level of the jet in the inlet pipe? Cannot siphon?

My cars spit out a bunch of water when I start them first time during the day..

If your plugs are black, then that is too much fuel which is what your blms are saying...strange with a Thrasher that it is not reading 128, tho....

I am not sure that a chip can go bad without throwing the ses light, tho. Have you tried another chip? It sounds like the maf, tho'.

What do your plugs look like if you pull them after it has been sitting for a bit and the engine is cool? Wet? Dry?



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 
1 - 12 of 12 Posts
Top