Turbo Buick Forums banner
1 - 20 of 49 Posts

·
Registered
Joined
·
637 Posts
Discussion Starter · #1 ·
Okay Here are my first 2 Powerloggs I just did some reading now and I guess I didn't hook my map sensor for the boost:mad:
 

Attachments

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts
You're not holding it to the boards...or you've got the weakest valve springs I've ever seen. Your TPS and MAF readings are telling me you haven`t got it at WOT.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #4 ·
Well I'm not sure about the Valve springs I had it pined for about as long as I could. And It might be the original O2.
 

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts
Your 1-2 shift point was 3600 RPM. Tough to tell what's going on without a WOT blast well into 3rd gear. Late in the file you did manage to get up to 89 MPH in 3rd gear. 02's are low at 740ish. Is your fuel pressure rising with boost?
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #6 ·
I didn't have my fuel pressure mounted on my windshield that run. But I didn't see any knock or my gauge and I didn't hear any pinging at all. The car was at about 15 psi of boost. The thing I don't understand is the logger logged 4 counts of knock but I've looked at the whole run and it sits steady at zero degrees? Whats the reason behind that.
 

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts
I see no KR on that log. 02's are low in 3rd gear at 89 MPH...which concerns me. Battery voltage is okay. Try to verify fuel pressure is rising with boost. If I was a betting man I`d say the pump is getting weak. I assume the car has a hotwire kit for the pump.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #8 ·
I see no KR on that log. 02's are low in 3rd gear at 89 MPH...which concerns me. Battery voltage is okay. Try to verify fuel pressure is rising with boost. If I was a betting man I`d say the pump is getting weak. I assume the car has a hotwire kit for the pump.
Yea it has the hotwire kit and walbro pump.
 

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts
How old is the pump...and is the chip burned for the exact combination. If not...then the chip may not have enuf WOT fuel...and you may have to add some.
 

·
aka: mOtOrHeAd MiKe
Joined
·
6,603 Posts
Before we go changing anything you should find a clear stretch of road and launch the car from around 2000rpm and let it run through the gears to redline (5000rpm) in 3rd. You need a baseline.

If your trans is short shifting 1-2 and/or 2-3 that is no good and will either need to be adjusted (TV cable), repaired (governor), or by-passed (manually shifted).

Do this and report back.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #11 ·
I agree with Motorhead I didn't really get to give her the full WOT I needed.. Granted its very hard to do a WOT on the public streets. Dose anyone know of a good Dyno to test tune on in Durham?

And would any tuners be willing to come with me to see the run. Also I need help with my powerlogger. I get no boost reading

:6:
 

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts

·
aka: mOtOrHeAd MiKe
Joined
·
6,603 Posts
Yes. Go to the track, spending money on dyno time is pointless at this stage.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #14 ·
If the weathers good I'll make a few passes.. It would be good to know my 1/4 Mile because at fist this car felt really fast to me now it fells regular. Do you think I'm just getting use to the power?

My guess is with the new 3" downpipe Alky kit and proper tuning it should be a whole new animal:6:
 

·
Registered
Joined
·
83 Posts
You can have 500hp. After a while it feels like driving a stocker again. Been there done that. That is when $$$ you start spending because it is hard for a gear head to say when do I stop. You think you will run faster than 13's .. With your set up??
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #16 ·
I think it would run 13's But I've learnt something from this video https://www.youtube.com/watch?v=YrM9NFHhl0Q The guy owns a Toyota Supra and we all know Supra owners have the same Bug as us when it comes to power. he went overboard and his car is in the shop more then not. I think once I get the 3" downpipe and alky I'll call it quits and focus on the looks of the car. A repaint maybe some 17" ccw classics lower the car a 1" 1/2. And a lot of maintenance to the suspension to get her to handle like a sports car.
 

·
YOU KNOW MY NAME!
Joined
·
5,673 Posts
Slide over to frame 6555. Your IDC is 72%...02's are 744...RPM is 4427 and your only at 89 MPH...and about 2/3rds throttle. Like the Molly Hatchet song...you're flirtin' with disaster.
 

·
Registered
Joined
·
83 Posts
Where should your 02's reading be at the rpm and mph.. ? on that frame? 6555. Good catch Brad. Better ensure your car is tune properly Spider before you hit the 1320.
 

·
Registered
Joined
·
637 Posts
Discussion Starter · #19 ·
See the problem with that is I have no idea what to do with that information yet. What dose that mean a part is broken ? or the tune isn't right?
 

·
Registered
Joined
·
2,008 Posts
file

See the problem with that is I have no idea what to do with that information yet. What dose that mean a part is broken ? or the tune isn't right?
Your running out of fuel,New fuel pump if its not new and injectors are needed.:cheers:
 
1 - 20 of 49 Posts
Top