Turbo Buick Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
Just fired up new rebuild. Oil pressure at startup ~95psi.

After warm up and low idle ~15psi

I've heard the 15psi is normal, but what about the 95? I have a hi-volume pump now, and I'm running Castol GTX 10W-30. Can the 95psi damage anything? Cause leaks?

Is there a way to adjust it? How?

Thanks
 

·
Registered
Joined
·
429 Posts
zr2tim said:
Just fired up new rebuild. Oil pressure at startup ~95psi.

After warm up and low idle ~15psi

I've heard the 15psi is normal, but what about the 95? I have a hi-volume pump now, and I'm running Castol GTX 10W-30. Can the 95psi damage anything? Cause leaks?

Is there a way to adjust it? How?

Thanks
Holy makeral!! Do you live in Antartica?? 95 is :eek!: ! 15 is even on the high side of normal for hot idle. I wish I could get 10! Sorry all I can do is confirm you need answers.
 

·
Resident Idiot
Joined
·
11,462 Posts
My oil pressure at cold start pegs the 100psi mechanical gauge and then settles to a hot idle of 20psi using 10/30w oil. IMO, that's not too high and isn't going to cause any problems.
 

·
Premium Member
Joined
·
43,735 Posts
You did not tell us what the pressure is when the engine is warm at normal speed.

Sounds about normal to me. Which spring did you put in the Pump?

As in any engine, one should not be revving it until the oil has warmed up and the pressure has dropped down toward the normal level
 

·
Registered
Joined
·
119 Posts
What kind of oil filter are you running? You'll probably be sorry if you are running the stock size. A Biggie or turbosaver setup would probably be a real good idea for you, you need something bigger with those big oil pump gears.

John
 
1 - 5 of 5 Posts
Top