Turbo Buick Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I am going to to put in my rebuilt motor/turbo in soon. I have new Bluetops that will be in it. Do I have to start the engine with the Thrasher 92 oct. blue top chip in it? I havent got the chip yet. The stock chip wont recognize the 36# injectors will it? I have a new Lunati 200/200 in it Ill have to break in. Thanks
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #3 ·
Thanks Steve, I would prefer to start it with the stock chip, because I thought the computer has to learn the new chip. Retarded timing is not nice on a break in!
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
22,915 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
I can feel your love for Steve, Zap.
I am still just A newbie Buick 3.8 guy needing answers periodically. I am assembling the motor right now. I already put a new dynagear stock timing set with new GM tensioner and roller cam button. When I put on my new HV pump/timing cover should I use the white spring (60 psi)? Also does the cam sensor have to be stabbed any particular way or just put in? How fast is your car Zap?
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
22,915 Posts

·
Premium Member
Joined
·
43,735 Posts

·
Resident Idiot
Joined
·
11,462 Posts
Personally I would use the correct chip. No sense in taking a chance of it running to rich when breaking it in. Chips are easy to change.... rings and oil aren't so easy.

------------------


Stock Block, Stock Cam, PTE-52, Champion Heads, V4, MSD50's, TH DP, JayJackson 62mm TB, 16position MaxEffort Chip. 3680# with Driver
12.0 @ 116.5mph w/20psi using 17.9* timing

mailto:[email protected][email protected]</A>
 
1 - 12 of 12 Posts
Top