Turbo Buick Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
It has been 2 weeks since i got my 87 grand national i love it but it has a few problems such as it has a very rough idle, it looks like it has a radiator leak ,the A/C compressor dosent want to turn on, there are a missing vacuum line on selinode going to the wastegate, and some bad wiring. I am not sure were to start. i should try to fix the parts or replace them? any help would be very cool.
 

·
Registered
Joined
·
6,966 Posts
I would start with the factory service manual which is a requirement for restoring the proper operation of electrical and mechanical systems on the car.

Gnttype.org also has a lot of that information.

Here are my guesses of your problems.

1. Reset IACV and TPS and check the chip for the idle. Also vacuum leaks. Need a good scantool such as the scanmaster.

2.Radiator leaks if very small try Prestone stop leak or time for a new one.

3. A/C should be leak tested and recharged, low side switch can be jumped for about 5 seconds to see if the compressor will run. First can of gas can go in the system without the compressor on, then it should cycle with the low side switch for the rest of the charge. If still using R12 have a pro do the work or convert it to R134A

4. Are there any lines to the wastegate solenoid? Should only be 1 on there. If 1 it is probably ok. If 0 it may be hooked up tuner style, check the hoses to the wastegate actuator itself.

5. Bad wiring, service manual diagrams or gnttype.org.

Lastly I would find a TR vendor to look over the car if you don't feel comfortable with the work.
 
1 - 3 of 3 Posts
Top