Turbo Buick Forums banner
1 - 15 of 15 Posts

·
Premium Member
Joined
·
43,735 Posts
Tell us the condition that it dies under.
 

·
Resident Idiot
Joined
·
11,462 Posts
I think #1 on the Ultrachip is 'Valet' mode and the RPM's are limited to 2000rpm or so. A very strange feeling if you accidently have the chip on #1 and try to cane the car... powersix
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
When my car is at an idle and I try to accelerate hard from a stop. It just seems to shut off. The ultrachip is usually set on #3 which limits boost to 17.6lbs, rev limiter at 6000, and spark timing at 18 deg. Any help would be apreciated, thanks.
 

·
Registered
Joined
·
1,838 Posts
Tip in stumble is usally corrected through the IAC setting procedure outlined in www.gnttype.org. If you want, just try backing the air bleed screw out a bit, and if that doesn't work try putting in in a bit. You will have to adjust the TPS aafter you do this. Again that procedure (setting the TPS) can be found at tha above link. Just do a search on TPS.

Good luck!
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
Just today I checked my IAC counts, They are at about 20. The IAC Reset procedures said that this is my target range. I also reset the TPS to .45v at idle, and 4.65v at WOT. I still have the tip in hesitation/stall condition. If anybody has and ideas I would love to hear them.
Thanks in advance.
 

·
Resident Idiot
Joined
·
11,462 Posts
Do you have a scan tool? A Direct Scan recording in the time period you are talking about would be invaluable.

How are your motor mounts? Engine could be twisting just a bit and the positive wire from the battery could have burnt through the header down by the starter.

This one is going to be tough to figure out without some sort of data logger... dunno
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
I don't personally have a scan tool yet. I was using a Snap On earlier today. You think direct scan would be the way to go? I will have to check my mounts and the positive battery cable. I'll get back to you on this. Thanks.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
The motor mounts apear to be ok. The engine does not shift too much when shifting into drive and such. The positive battery cable to the starter is fine but the two other wires attatched to the starter soleniod apear to be corroded and in bad shape. Do you think these wires could be causing the problem?
 

·
Fuhgeddaboudit
Joined
·
18,613 Posts
[email protected] is good. TPS @ 45 Idle is Ok but 44 is better but won't solve your problem. I would make sure the 02 sensor is good. If dead it will give a bad tip in stumble. Also Fuel Pressure too low or too high will cause it. Being in Colorado altitudes the normal settings may need to be adjusted a little. Try 40 then try 46 see which is better. Then adjust around that number. I assume you have no vacuum leaks or cracked exhaust manifolds..
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
Earlier today when I checked, the o2 sensor voltage was normal. I will have to put my fuel pressure gauge on it to see where it is at and adjust if needed. Thanks for posting
 
Joined
·
11 Posts
It could be a fuel filter starting to get blocked.
Remove filter, if it feels heavy after it is drained or if you can't blow through it ,it is blocked. You should be able to blow through it very easily no restriction.


Brotherhood of Bad Buicks uzi
87 Turbo T WO2 light with fright :mad:
I am new here usa
 

·
Premium Member
Joined
·
43,735 Posts
does the car miss when you kick it down from a roll?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #14 ·
I checked my fuel pressure today and it was at 35psi, I put it at 40psi and it seemed better (still a hesitation but no stall) Tried 45 but it was worse than 40 so I put it back, didn't have alot of time to keep trying so I left it at 40. It does seem to miss when I nail it from a roll now that I pay attention to it, I guess I've just been caught up in this stall problem. Also my SES light came on and flashed a code 45 (rich exhaust condition) If you guys can help it would be great. Thanks
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #15 ·
Oh, and being that it is "spring cleaning" time I definetly plan on replacing the fuel filter just for good measure. I would kick myself if thats all it turned out to be. Thanks for posting.
 
1 - 15 of 15 Posts
Top