Turbo Buick Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
Alright I'm very confused. I have a maf translatr on my GN and have no idea how it works. Car runs great scanmaster #'s good except for blms pegged at 150. I'm running lean, computer adding all the fuel it can??? I cant find any vacuum leaks and no exhaust leaks. Could my translator be set wrong causing my high blms? I downloaded directions from full throttle, still really foggy on this. Are there any good artices/ websites? I hate not knowing whats going on with my beloved buick!! Thanks
 

·
Registered
Joined
·
323 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #3 ·
43# line off
 

·
Registered
Joined
·
323 Posts
If you unscrew the top of trans + off what are all your settings on your switches fuel is fine though.
 

·
Registered
Joined
·
323 Posts
When settings are checked and if look ok i would look for vacuum leaks or possible bad pcv or stuck open egr, if no vacuum leaks are found let us know.
 

·
Registered
Joined
·
185 Posts
Discussion Starter · #6 ·
Setting are switch 1 on 2on 3 off 4 off
base knob 5 wot c
I dont know if my pte 20* street chip is a extender chip That will effect the 3rd switch?
 

·
Registered
Joined
·
323 Posts
switch #3 is on, on my application the definition says
on=output signal limited
should also be set to on for gn/ retrofit vehicles that are not running extender chips

I would call Mike at Full Throttle, if even bought used he will help answer any of your questions i'm sure.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top