Turbo Buick Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Had three MAF's in the car in the last couple of days, the frist was at 3g/s. The second was 4 g/s and the third 4-5g/s. The car idle sucks. Any thing I should try to fix this problem? A little info IAC 21 LV8 36 TPS .43 O2CC 16 INT 124 BLM 116 MAT 72.5 PROM 1966 COOLANT TEMP 167 RPM 725 BATTERY VOLTAGE 13.8 CLOSED LOOP
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #3 ·
In September of 02 I replaced all sensors. Including the MAF, just got turbo-link and found low MAF readings. Been doing the adjustments above to try and improve idle. At 4 or 5 g/s it idles better, what is it really suspose to idle at. How many grams a second does it really use. I posted before and was told 6-7 by most. After three new MAF's the bes one read 4-5 bouncing. Is this why I read alot about MAF less?
 

·
Premium Member
Joined
·
43,735 Posts
I would think 4-5 at idle is a good maf reading.

Have you cleaned the throttlebody?
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #5 ·
What are you cleaning? The IAC port? IAC port had a little oil in it, not bad. My turbo let loose had a quarter inch of side play,a lot of oil in intercooler. Just replaced turbo. Cleaned the intercooler and the IAC port. Anything else?
 

·
Premium Member
Joined
·
43,735 Posts
just the ports between the iac location and the inside of the tb plus the inside of the tb and the ports leading off from the mouth of the tb
 
1 - 6 of 6 Posts
Top