Turbo Buick Forums banner
1 - 8 of 8 Posts

·
Missing 2 Cylinders???
Joined
·
1,150 Posts
Discussion Starter · #1 ·
Just took the car out for a little testing. Didn't realized it, but I blew the top rad hose off. I went almost a mile before I seen that it was 258* eek! That was the hottest it got, but I'm not sure if it's hurt or not. After it cooled down, I filled the water, started it back up and WATCHED. It got up to 175* and I shut it down, I nomrally see about 160 to 165*. What should I be checking? And do you guys think I hurt it?

No funny sounds and as far as I can tell, oil looks ok.

<small>[ March 23, 2003, 04:09 PM: Message edited by: Getchasum ]</small>
 

·
Premium Member
Joined
·
43,735 Posts

·
Premium Member
Joined
·
4,825 Posts
there's a real good chance that the 258 was a false reading. when you coolant level got low, you might have had "boiling hot" steam hitting the temp sensor instead of "cool" 180* coolant.

earl
 

·
Registered
Joined
·
6,966 Posts
You might be okay. Had a couple of similar experiences.

When I have cold water in my car the 160 stat. opens exactly at 180 the first time and then it sits at 160 all day.

I'd check the water level and fire it up and see if it goes to 190 or when it hits 180 if it drops like a rock when the stat. opens. :)

Just my .02 you might be okay.

Look for bubbles in the coolant tank too. frown
 

·
Missing 2 Cylinders???
Joined
·
1,150 Posts
Discussion Starter · #5 ·
When I fired it up the thermostat opened at 160*, I could tell from SM, that's when it started to climb back to 175*. It be my luck, I let the car set for 8 years, spent all my time and money over the last two years, just to hurt it.
 

·
Premium Member
Joined
·
43,735 Posts

·
I'm the Best!
Joined
·
14,818 Posts
my car on the highway runs 180 in the summer with the ac on.
 

·
Missing 2 Cylinders???
Joined
·
1,150 Posts
Discussion Starter · #8 ·
UPDATE!

All is well. I hope I never have that scare again!
 
1 - 8 of 8 Posts
Top