Turbo Buick Forums banner
1 - 5 of 5 Posts

·
Resident Embraer Driver
Joined
·
1,160 Posts
Discussion Starter · #1 ·
Today I just finished puting on my new TA-49, 009's, and my hooker exaust. I got Lubrants 93 octane chip and set the boost around 17#, any higher than 17 I'm showing knock with 93 octane. With the boost set at 17 the problem is there is no tension on the actuator and there is probably a 1/4 gap or 3 to 4 turns on the actuator away from the spot where there is tension and the car spools up very slow. when I move the actuator rod so I have tension, the turbo spools up very quickly but I cant get all the way into it because I get to much boost and it shows knock.

So my question is, can I eliminate the computer controlling the boost? When I had the stock chip in with all the stock parts the stock chip spooled up faster than all my aftermarket chips because I dont think the stock chip has boost control built into it.
Any Idea's? thanks for the help

Joe

------------------
1986 Grand National
TA-49, 009's, Hooker cat back, and all the other usual stuff

 

·
Registered
Joined
·
1,293 Posts
Joe Lubrant can fix you up with a chip that has no boost control'My 93 & 108 dont have it.Im sure theres others that can do the same that burn chips.The stock chip does have boost control.

------------------
Keith Davis---"Putting it together!:)86GN,Astroroof,DigDash'TTA crank,Ported polished heads & intake'TRW .30 forged pistons & PT51 Turbo,Manly SS valves,Postons headers,T.C. Orange stripe conv.THDP,SMC alky,Boost command,Scanmaster2,MSD50 inj,Nitto DR's 275/50/15,All the braces,All gauges VDO.


 

·
Resident Embraer Driver
Joined
·
1,160 Posts
Discussion Starter · #3 ·
TTT
anything else I can do, umplug the boost control selenoid??

------------------
1986 Grand National
TA-49, 009's, Hooker cat back, and all the other usual stuff

 

·
Premium Member
Joined
·
43,735 Posts
You can run a hose straight from the compressor housing port to the actuator and use the wastegate rod to set the boost....

If you have a stock actuator, shortening the rod about a tenth of an inch so that tension is on the gate will give you 14-15#. Shortening more wil increase it to the level you want it.

The "Y" hose is not used in this case.
 

·
Premium Member
Joined
·
307 Posts
Did you happen to put a new wastegate hose assembly on? If so, the restricted orifice may be too small, try replacing the plastic y portion with your old one.

Mike
 
1 - 5 of 5 Posts
Top