Turbo Buick Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #1 ·
Houston we have a problem here....

I have white smoke out the tailpipes.

What could be the causes?

How much should the job cost to repair both sides?

Should I drive it 12 miles home, runs fine.

3.3 KR at 20psi boost that was it...
 

·
Fuhgeddaboudit
Joined
·
18,613 Posts
If you have NO water in the oil then I would take a chance. Loosen the radiator cap so it dont build up pressure. After you get it home then its time for testing.

------------------
ED BAKER
87-T-TYPE, PT54,MSD50's,Crane Billet Roller,JE forged20over,P&P Heads,Manley valves,Hemco 65mm& Acu65TB,V2 FM, P.I.9.5 -7disc,Jimmys Trans, new times soon.
93 PARK AVE"SUPERCHARGED"
67RS/SS350 CAMARO
mailto:[email protected][email protected]</A>
http://www.modernmusclecar.net

[This message has been edited by ULYCYC (edited January 28, 2002).]
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #3 ·
Thanks Ed.

Started it at lunch and no smoke for about 1 minute running. No water buildup in a cylinder which I would have expected???

Anyway idled fine gonna go check the oil and run it another minute.
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #5 ·
I am not sure of anything, could have been the overflow dripping all the way down the downpipe I guess and burning off, I did smell antifreeze and saw smoke at the end of a 12 mile drive I wouldn't think there would be condensation but it was a weird day here today cold in the morning warming up to 60.

Going for the ride home, hopefully....

Didn't start it again wanted to keep it cold.
 

·
Fuhgeddaboudit
Joined
·
18,613 Posts
Zap is right(did I say that??) Your heater core may be leaking or a freeze out plug dripping on the exhaust. But white smoke wont come out the tail pipe from that??

------------------
ED BAKER
87-T-TYPE, PT54,MSD50's,Crane Billet Roller,JE forged20over,P&P Heads,Manley valves,Hemco 65mm& Acu65TB,V2 FM, P.I.9.5 -7disc,Jimmys Trans, new times soon.
93 PARK AVE"SUPERCHARGED"
67RS/SS350 CAMARO
mailto:[email protected][email protected]</A>
http://www.modernmusclecar.net
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #7 ·
Ummmmm, false alarm I guess.... oops.

No smoke on the ride home and I did do one 10 psi boost near home.


Just a combination of strange events occurring in the past 24 hours including a visit from Mothman.


Put the HRParts motor mount on, and, I think I jacked the engine up a wee bit much. I now have an exhaust bracket making metal sound in the exhaust, the front end didn't feel quite right this morning, no clue why, and there definately was smoke in the tailpipes and an antifreeze smell in the air when I got to work. Plus the fact that I was test and tuning a coupla times at 20psi on the way in to work. I checked the alky. pump, but not the spray pattern yesterday. Shoulda checked the flow and mist too.

I guess all is well now excepting the banging in the exhaust pipes, there's no real smell and no more smoke. Oil is fine and water level is just above full hot where it was yesterday when I checked it before doing any work. Soooooo....

Story time: UPS guy shows up while I am out looking for water in the oil and says he has two "race" tires for me. I say great just roll them down the driveway here and I will put them in the basement.

He brings them out and says, "Do you own a racecar, these are racing tires." I tell him no I don't have a race car and tell him that these are drag radials you can actually use them on the street. He says, "Oh what kind of car are you gonna put them on?" At this time I was looking at the GN under the cover and listening to the pinging exhaust, so I just say, not sure one or the other...

He gives me a funny look and says, "This car!?" At this point I wasn't concerned about salvageV6 anymore so I stand up out of the engine bay and tell him "Yeah this is the faster one." He says, "Oh".

I tell him it's turbo charged, see there's the turbo while pointing to it. Then I say it probably won't spin these monsters though.


He was kinda confused and walked away looking at poor old salvageV6 and shaking his head. I got back in the engine bay and revved it up for him just as he got to the back of the car. I still don't think he was too impressed LOL.

Those Nitto's are nice.
 

·
SCONE WIZARD...
Joined
·
704 Posts
Originally posted by Zap:
Faster than your big brown truck, Jerk!


Well, if there is anything wrong, just wait until it tears completely up, then fix it. That's what I do. It makes troubleshooting a lot easier.
I like Zaps logic here




------------------
DTA... don't trust anybody...
- - - - - -
Steve Ruston
1989 Mustang LX Coupe
5 speed, mostly stock w/ small mods... For now anyway :D
1976 Chev Caprice Classic,
96000 miles, Red, 400 SBC, TH 350, BIG heavy chrome bumpers..
Daily driver, parts chaser, traffic buster & your worst nightmare if you park too close to me at Walmart :D
1987 Turbo Limited--> Sold Nov 2001
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #11 ·
Actually I have considered the plate, I have a Jay Jackson throttle body and upper to put on the car and also have a Kenne-Belle 1/2" spacer to get rid of.

Does the plate work with, or replace a Kenne-Belle phenolic plenum spacer?

Just waiting for the group purchase.
 

·
Registered
Joined
·
1,838 Posts
I've got rattling from the exhaust. I believe that it is the result of conditioning the cat with a pipe, and ball peen hammer. Took a while, but something worked loose in there and at 1500 rpm or so, it makes a rasping sound.
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #13 ·
Mines more like a ricer with a loose fart can exhaust.


It hit 60 something here today I should go home now and fix it.


Other than that the headgaskets are really OK. No KR at all at 15 psi.

Gonna shoot for 19 on the way home...

Whooooeeeeee!!!

Winter we don't need no stinkin' winter...
 
1 - 13 of 13 Posts
Top