Turbo Buick Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #1 ·
Darn new GN just won't run right.

Waiting on new wires but I pulled the plugs and all fire ok no strange deposits.

Random misfiring/roughness at idle smooths out some with more than 2K throttle but not perfect.

No codes. Reds 93 chip and stocker same thing. Fuel is 40psi. hose off adj. reg. and good pump and filter.

EGR is ok, changed MAF, O2, ECM, coil pack, all ok. MAF hose turbo shaft and compressor wheel all ok. IACV set up to 10 or so. New K+N filter too.

Car does have some header leaks you can hear them and blms go to 140 or so at idle. Spools ok however but doesn't run that smoothly.

I'm thinking fuel inj. Car has new timing chain also. Maybe I should change out the module or the crank sensor?
I guess it's time for a compression check also???

Anything else to do?
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #2 ·
Hey Steve, think that infrared gun trick is worth trying? We have an 80K one at work, not portable though.....


I think one of the other depts. has a portable one, might have to borrow it for a day
.
 

·
Registered
Joined
·
246 Posts
Just curious...when you change your sensors do you use genuine (sp?) AC Delco parts?
I hear electrical and ignition related parts are best purchased from the dealer.

I learned my lesson yesterday with o2 sensors....Niehoff vs. AC Delco...

Guess who won? Now my car runs great!

Circumsize your vacuum hoses as well....where applicable...I did that as well. Don't know for sure if that helped my problem, but it does put my mind at ease.




------------------

1987 GN: 104,500 miles, 160°T-stat, homemade dual exhaust with Dynomax Super Turbos, Adj.WG, Walbro 340, Adj.FPR, chrome MAF pipe w/12"K&N cone, engine tie-down, SCANMASTER II, 30psi VDO Boost gauge, 235/60/15 DUNLOP GT QUALIFIERS all around, custom chip. Set at a confident 15lbs of boost 14.4 ET @ 91.7mph is STILL MY BEST---- :( WTF?
...BEFORE the above mods were done!
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #5 ·
Yup A/C Delco, been there done that with the Bosch O2's.....

A/C Delco brand new MAF's also....

Hoping it's only fuel....

I ran the car with the drivers side cover off it. Valves worked I think, can you see a flat cam lobe?
 

·
Registered
Joined
·
22,915 Posts
Probably could, but I finally tore my engine apart after getting tired of trying to find the problem. Would prolly make a tapping noise too.

My car had no power (no hotair jokes here please) and generally drove like crap. I would worry about the cam as a last resort.


PS If I ever go look at the 67 Riv GS I'll let you know what it looks like. I do know it is white with a tan interior (or so the add says).



[This message has been edited by Zap (edited August 05, 2001).]



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #7 ·
Yuck!
That pretty well somes up my reply to your post there Zap. Hoping it ain't heads or valves but I did hear a funky noise for a second when I did the top engine clean....

No rapping I don't think in the valve train area. Hard to tell with the exhaust leak...

Anyway I'm thinking the cam would be the same cylinder not firing and rhythmic not random misfiring like I think I have. ???

White is ok but tan interior? ummm yuck...

Thanks for the injector offer, but my wallet is open so far with this car and I think I'm gonna get another set of Bosch greentops since I have the chips already....
 

·
Registered
Joined
·
22,915 Posts
I would think you would be correct about the random misfire. Mine made a very strange rythmic noise when being driven, similar to an exhaust drone but less frequent.

Funny thing about the Riv. First week it was advertised as excellent condition for 2400. Second week very good condition and 2200. Now it is in good condition for 2000. It's going downhill fast!




Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #9 ·
Yeah mines down to the wheel wells right now, it'a amazing how far down a 4500lb. car can go....


Hope my wires show up tomorrow! I wish I remembered to do a compression test when I pulled the plugs....
 

·
Registered
Joined
·
22,915 Posts
Send Steve a ticket and he will fly up and fix it. I think he wants to kill someone in the Boston area anyway, so he could (literally) kill two birds with one stone.

(yes, I know Boston is in a different state, still New England though, rambling again, I know)


[This message has been edited by Zap (edited August 05, 2001).]



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
 

·
Premium Member
Joined
·
43,735 Posts
yes, I would like to kill someone in that area....

I would run compression check first but it certainly sounds like an injector possibility.

I always look for steady vacuum first just to try to rule out leaks etc.

those infrared guns are pretty handy....
 

·
Registered
Joined
·
1,202 Posts
My car has similar problems, only more intermittantly. I'm attacking it with wires and new 009's. If this doesn't fix it I'll let you guys know.
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #13 ·
Well I just have to say salvageV6 runs great on alky. The new GN is driving me nuts.

Vacuum is not steady at idle varies 2-4 inches of mercury, along with the rpm miss and catchup.

Steve who do you want to kill send me an email I need the money?....


Glad I came over here at lunchtime have to go ask to borrow the poratable gun.


I should be ordering injectors too....
 

·
Registered
Joined
·
221 Posts
Hey Mr. ZAP. Seeing how you are always the one to give people hell and enjoy it. Let me ask you this. When did Boston become it's own state? You yanks changing things up there and not tellin us southern boys?
 

·
Registered
Joined
·
221 Posts
DOH....Sorry Mr. ZAP you did say, "in a different state." My Bad or Bat or what ever it is folks say. Damn thought I had a chance to stick you once like you do everyone else. I'll keep watching.
 

·
Premium Member
Joined
·
43,735 Posts
A dealer in the Boston area. We bought a T that was described as a solid 8 out of 10 car with patched floor pan.

Turned out, it did not have a floor pan for the most part....Had a bunch of pieces of tin trying to cover the holes. Only two solid brackets holding the driver's seat. Rust in the wheel wells, rust coming thru the trunk seams....

LOL...best looking car I ever saw until I looked at it up close...got our money back but lost the shipping....Thinking about suing for false representation.
 

·
Registered
Joined
·
221 Posts
Steve's not gay, they don't allow them in Texas.
WV - I don't know my history but that's north from here.
10-4 on the confused
Boston is where they Pak Ya Kar ! now those folks are yankees.
 

·
Registered
Joined
·
6,966 Posts
Discussion Starter · #19 ·
"West Virginia was the only state to send relatively the same number of Union and Confederate veterans to the Battle of Gettysburg reunion, another symbol of the divided state created by the Civil War."


No wonder Zap is schizo....

Technically they are North but....

Okay nothing wrong with Yankees they have a good baseball team too.


Sorry about the problems up North here Steve.


PS: The war is over. Thankfully we are one big happy Nation!


Oh yeah almost have the car fixed..... separate post on that....
 
1 - 19 of 19 Posts
Top