Turbo Buick Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
After about 10 minutes of driving the car my "fasten seatbelts" indicator comes on for about 10 seconds. It will do this randomly while driving the car. Why is this caused? Can it be helped? Or is the car as crazy as I?
 

·
Premium Member
Joined
·
43,735 Posts
Little black box up under the dash, behind the radio has gone wacky...it controls the lights, buzzers, etc.
 

·
Registered
Joined
·
6,966 Posts
My "new" GN does this too, drives me crazy....

Gonna pull the lamp since I unplugged the connector in the seatbelt anyway.


Rest of the little black box works fine in the car so I ain't touching it.
 

·
Premium Member
Joined
·
43,735 Posts
Convenience center is what I think GM calls this thing....certainly not from the location
 

·
Registered
Joined
·
84 Posts
Discussion Starter · #5 ·
Hmm. Thanx for the info. If I go about fixing this thing I wonder if there is a way to wire it to my volt booster so it goess on when 10 psi hits. Then I can be like knight rider
 
G

·
Mine used to come on frequently, then I dropped the panel under the dash and pushed the box all the way in.. now it only comes on when I hit a good bump. One of these days I'll replace it.. when it gets too annoying.

Ken

------------------
87 GN - 52K, 30# green stripe injectors, adj. regulator, adj. wastegate, 3" Up-pipe, Tomka cold-air induction, XP pump hotwired, Hooker exhaust, Hi-Flow cat, Scanmaster, KYB Shocks, Eibach springs, Optima battery, Full power, Broken antenna.
 
1 - 7 of 7 Posts
Top