Turbo Buick Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
I was under the impression that when I shut the car off and it is hot the fan will stay on for some period of time. Mine goes off with the engine.

If I turn the car to 'run' but don't start it the fan will come on.

Is something wrong????

Also, I thought if I shut off the air it would stay on for a few seconds.....it goes off with the air going off, assuming the engine is not warm enough for the fan to be on anyway.

Thoughts?
 

·
Registered
Joined
·
59 Posts
It depends how hot the car is. I think that it needs to be around 222F. My fan seems to only run in the summer months. In the winter it is unusal for the tem to get high enough.
If your temp is around 220+ I would change the fan timing relay. It is one of the three on the drivers side.
Check www.gnttype.org to see which relay it may be.
Hope this helps
 

·
Registered
Joined
·
349 Posts
The biggest of the 3 relays on the driver's side inner fender is the fan delay relay. Most of the time this is the culprit for the fan not running after the engine is cut off. As mentioned above, the car must be at a certain temp. for this to happen. If you are using a 160* thermostat & your radiator is in good shape, unplugging this relay may be something to think about. They are notorious for acting up on occasion & coming on at odd times & running until the battery is drained. Ask me how I know.
They are fairly inexpensive though if you want to replace it. HTH
 

·
General Useless POS
Joined
·
1,801 Posts
It also depends on the chip. When I had my JC chip in the car, it did that, as well as the ATR PitBulls. I saw no reason to run the fan all the time so I set mine to come on at 169 in my own chip(s)

The fan will only stay on after turning the key off it the HIGH SPEED fan was triggered prior to turning the key off, THEN the fan will run for 7 or 10 minutes ..whatever the time is..

------------------

Jim Testa
1986 Regal T-Type
Stock block, Turbomotion ported heads, PTE 210 roller cam, GNT ported intake, PTE Plenum, 70mm TB, PTE FM IC, MSD 50's, TE61, TPS-TEC, JT Chip, JT 200R4, Vigilante 2800 LU convertor, JT Boxed lower arms, working on girlde....
 

·
Registered
Joined
·
2 Posts
Originally posted by TurboJim:
The fan will only stay on after turning the key off it the HIGH SPEED fan was triggered prior to turning the key off, THEN the fan will run for 7 or 10 minutes ..whatever the time is..
Does this include if the A/C is on? I have the same problem and wasn't sure if it was the relay with the delay. The only time I have noticed the high speed mode is when the A/C is on (which I believe is by design) and the engine is running (not sure about engine not running and ignition on). Haven't seen the temp above 210 and running a Thrasher92.

Tom
 

·
Registered
Joined
·
6,966 Posts
The high pressure A/C fan switch operates both the low and the high speed fan.

Low speed with A/C when the pressure is over 260psi.

High speed when the pressure is over 300psi.

If the fan was operating at high speed with the A/C on prior to shutdown the delay relay should be triggered and operate.

Hope that helps some.
 
1 - 6 of 6 Posts
Top