Turbo Buick Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
I'm going to englishtown next week, but my cars failing. Heres the problem, my 87 GN has the old Kenne-Bell cold Air system setup. Well It is a Kenne-Bell filter and has this big black Kenne-Bell Canister that the filter goes in and theres a tube that runs to the bottom of the car and connects to the front air dam. Well I got rid of the tube that connects to the air dam. Also I took off the canister. Now I have the filter showing, I like it that way. Anyways when I started my car it would die. Then I put the black canister on so the filter is inside. I turned on the car and it ran fine. Then I repeated the process. It seems like my car hates it without the black Canister. But I dont want the Canister. I want the filter showing, but it wont run good. Whats the problem here.

Oh, by the way, theres a hole on the neck of the filter. Thats where my MAT is located.

PLEASE HELP.
 

·
Registered
Joined
·
1,197 Posts
By chance do you happen to have a Kenne Bell chip in there? If so....
Maybe your chip knows you are taking off the KB stuff. And is just being irritable.

Seriously though.
There are no sensors or anything hooked to the section that you are taking off right?

I would suspect that when the tube is hooked up. There maybe less viberation.
And when you take it off. There is more viberation which maybe effecting the MAF sensor.
Just my only logical guess as of this moment.

HTH -Matt-

<small>[ April 21, 2003, 07:17 PM: Message edited by: Toadie's T-Type ]</small>
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #3 ·
The chip part makes sense, but where would it be loacated. There is no other sensors, the only two are the MAT and MAF.
 

·
Registered
Joined
·
6,966 Posts
Did you wash the filter lately?

Damage the MAF unhooking the KenneBell stuff?

If you go racing you should know exactly what chip is in the car and how it is supposed to work.

I'd use some real good gas otherwise.... eek!
 

·
Registered
Joined
·
1,197 Posts
GNRacer:
The chip part makes sense, but where would it be loacated. There is no other sensors, the only two are the MAT and MAF.
I was just running my mouth about a kenne Bell chip giving you problems because you were taking other Kenne Bell stuff off.
I would honestly think your problem lies within the Maf sensor.
However.
If you wanna check your chip take the Kick panel off the passenger side.
Make sure the ign. is off. Once you get it seperated. Take the 2 screws off the little plate on the 1 side.
Then look at the smaller chip. Write down the info that is written typed stamped on it.
post that info here if you want.
Helps others in figuring out any problems you may have.
I know I'm still learning alot about our cars.
I've had mine for 2 years now.

HTH -Matt-
 

·
Registered
Joined
·
178 Posts
I had a KB ram air set up like the one you have.( got rid of it and got Big mouth cold air set up, hell of a lot better and the sound it makes is wild). It should have no effect taking the canister off, all you have then is an open air set up. Alot of guys have this and have no problems. Unplug the orange wire next to the battery next time you take the canister off to clear the ecm. If you still have problems I say you have a MAF issue.Chup has nothing to do with it.

John
 

·
Premium Member
Joined
·
43,735 Posts
Most of us long term owners thru the cannister away long ago. It is very restrictive. Car should run better at wot and should not be a problem at idle. Strange that it works okay when you reinstall the cannister. That would indicate, to me, that the car is way lean and richens up when you restrict the air flow. I don't think that is the problem...or it should not be the problem.
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #8 ·
Well, a couple of months ago, I took my 87 T-type computer and i switched with my GN. So I have a stock chip. But if my car is running to rich, how can i fix that problem, and also i just got a new MAF. Maybe getting a big mouth will solve this whole problem. Thanks for the help guys, this Forum kicks rulez. I'm learning more each day on this car
 

·
Premium Member
Joined
·
43,735 Posts
Big mouth should not affect it one way, or another. Something is screwy if it dies with an open element as opposed to one in the cannister.

Will it idle at all? What are your scan tool readings at idle?
 

·
too many toys
Joined
·
1,206 Posts
Do a simple test.Place a piece of cardboard between the engine fan and the air filter.Does the problem go away?If so then you have a problem with fan wash.Not all MAF meters have this problem,but for the ones that do its a pain in the ass. :D
 
1 - 10 of 10 Posts
Top