Turbo Buick Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I had to be towed home tonight. The car died and would not restart. While waiting for my friend I started checking things out. I could not hear the fuel pump engaging but we were by a well populated road so I couldn't tell if traffic was drowning it out or it wasn't running. I hooked a fuel pressure guage up to it and it showed 20lbs. I had the wife crank the car and it did not go any higher. The car cranked like normal but just wouldn't start. When my friend got there we tested it again and it had 0lbs. and it did not increase. After we got the car home it started right up. My friend said it might've just gotten stuck and when I towed it home it loosened it up. Does this sound like a normal fuel pump going out or could it be something else that is masking itself as a fuel pump. I hooked the DS up with the ignition on and all the readings looked normal except of course the fuel. When I first hooked up DS it fluctuates while idling between rich and lean. I also had to keep boost around 10lbs or it sees knock. I am assuming the chip is older because at idle it is showing 22-23 degrees of timing and under acceleration it goes up into the 40+ degrees range.

Thanks,
Ken
 

·
Registered
Joined
·
46 Posts
what kind of pressure are you getting now??? It should be in the 40-45lb range... Then it should go up with each pound of boost..I would not drive it far, in that condition , it may be running lean... eek! and that is real bad!!!!
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
I did not test it after it restarted. I moved it over in the garage so I could get the wifes car in and left it. I do know I had the fuel pressure set at 45lbs before that. When you check fuel pressure on these cars do you have to pull a vacuum line or is it just what you see when you hook up the guage?
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #5 ·
Ok. I had 45lbs. with vacuum. I will set it to 45 without vacuum and I will get me a new pump ordered. Would you guys recommend a 307 or 340 pump? The car is in sig. and I will be adding Hooker 2.5" exhaust with 3" Mease DP and cat. I will also be adding an SMC alcohol injection kit and a Jim Testa chip. My goal is mid 12's on pump gas.
 

·
Registered
Joined
·
6,966 Posts
340

If it is an upgraded pump already you might want to first look at all the electrical connections to the system.

Is it hotwired?
 

·
Premium Member
Joined
·
43,735 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #8 ·
The pump is hotwired. Originally I thought I had some electrical gremlins but it turned out to be an ignition switch that was not working properly. I have only owned the car for 2 weeks so I am not sure much about it. I unfortunately have been sinking all my money into trying to get it emissions legal for my area. The car has a test pipe with dump and straight 2.25" exhaust with no mufflers.

I know there are quite a few things that aren't what I would've done due to me being a perfectionist. The last owner had a exhaust shop do the piping from and to the intercooler which are not mandrel bent. A friend of mine has said I am probably losing 7+ lbs of boost due to the bends and crimps. I have a lot of work ahead of me so I will probably be asking lots of questions. Good thing I got a reasonable price.

Thanks to everyone for the help,
Ken
 
1 - 8 of 8 Posts
Top