Turbo Buick Forums banner
1 - 14 of 14 Posts

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #1 ·
well a while back (long long time ago) my brake light would come on when i hit the brake fast. i've herd it was the acumulator ball. now when it comes on i get a hard pedal when the light goes out i get a normal pedel. is that the ball?
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #2 ·
ttt
 

·
Gone and almost forgotten
Joined
·
1,042 Posts
My reply would be a firm "maybe"......

Does the motor still run and switch off within 7-10 seconds ?

When does the hard pedal occur ? Is it frequent ? Is it after a few brake applies ??

The GN T-Type page is back up and has a ton of good information and troubleshooting charts:

http://gnttype.org/techarea/brakes/brakespage.html
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #4 ·
it does it all the time. the hard pedal is when you hit the brake then it goes away.
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #5 ·
well i guess i'm going to have to change the whole unit.. :rolleyes:
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #7 ·
no.. could that be the problem?
 

·
Post Ho
Joined
·
3,628 Posts
When you hit the brakes and the light comes on, does the light stay on briefly and then go out?If so it sounds like the accumulator ball.With the cost and availability of balls accumulator balls these days I hate to guarentee anything being that I'm almost 500 miles away.Accumulators are pretty expensive so I wouldn't want you to go out and buy one if you don't need it.Does anyone nearby have one you can try?I may have an old used one kicking around somewhere but I wouldn't know if it was still good after sitting for years. :dunno:
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #9 ·
it does come on briefly then goes out then flashes then goes out. you can feel a clicking in the pedal though. i dont care about spending the money on something like this.. you kinda gotta stop when there are cars infront of you! :crazy:
 

·
I'm the Best!
Joined
·
14,818 Posts
Discussion Starter · #11 ·
i'm going to change the acc. ball when brian gets a few. i'll post results. this will be in another month or 2.
 

·
Registered
Joined
·
34 Posts
switch

I can't remember exactly, and maybe someone can help. But there was a change in the switch that mounts near the ball. I can't remember but I think you replaced grey with black switch. If it goes bad the motor won't run and it won't charge the accumulator. My guess is if the pump runs if you pump the pedal about 10 times and then goes off that the accumulator is the highest percentage cause. Make sure you pump the pedal with the key off for at least 10 if not 20-30 times to be sure the ball is discharged!! Never hurts to replace the switch if the recall was never done at the same time.
 
1 - 14 of 14 Posts
Top