Turbo Buick Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
430 Posts
Discussion Starter · #1 ·
my brake pedal has a deep travel before I can feel the brakes kick in. Do I just need to bleed the brakes or some part of the powermaster has to be replace?

------------------
87 GN Hardtop~ stock motor, stock intercooler, TE 51 w/.63 exhaust housing,big mouth cold air induction, hotwired walboro 340, MSD 50's, cold air induction, stock TB and plenum, THDP, 3" ATR dual exhaust, 10 mm Magnecor wries, B&M tranny cooler, performance transmissions deep aluminum pan, Dynotech shift kit, VDO gauges, Autometer boost gauge, SMC alchy injection, PTE remote oil system, ATR 3" maf pipe, scanmaster 2
 

·
Registered
Joined
·
10,284 Posts
No buldging flex hoses front or rear?Rear brakes adjusted right?

------------------
Give em' hell!
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #3 ·
i probably have to get the rear brakes adjusted. Haven't done that ever since I bought the car.
 

·
Registered
Joined
·
63 Posts
I have the same problem. I ended up bleeding the brakes and the rears are all new and ajusted and nothing has changed.

------------------
 

·
Registered
Joined
·
1,293 Posts
If you have air in the brakes they will pump up"If your rear brakes need adjusted you will have a low petal"If theres no air & the brakes are adjusted right"& you have a low petal you have a bad master cylinder or power master.
 

·
General Useless POS
Joined
·
1,801 Posts
Push down the emergency brake and see if the pedal changes. If so the rears are our of adjustment, if NOT then you need to look elsewhere. If you have the old iron prop valve you most likely have ingsted air over the years. Bleeding the brakes usually fixes that.

------------------

Jim Testa
1986 Regal T-Type
Stock block, Turbomotion ported heads, PTE 210 roller cam, GNT ported intake, PTE Plenum, 70mm TB, PTE FM IC, MSD 50's, TE61, TPS-TEC, JT Chip, JT 200R4, Vigilante 2800 LU convertor, JT Boxed lower arms, working on girlde....
 

·
Registered
Joined
·
84 Posts
I have a related problem.
When I hit my brakes I get a funny electrical high pitched buzzing sound from the dash/brake area. WHat could this be
 

·
General Useless POS
Joined
·
1,801 Posts
Thats the powermaster pump turning on. It shouldnt happen every pedal application, but more every 2-3 applications. If its happening every application the accumulator is losing its charge.

------------------

Jim Testa
1986 Regal T-Type
Stock block, Turbomotion ported heads, PTE 210 roller cam, GNT ported intake, PTE Plenum, 70mm TB, PTE FM IC, MSD 50's, TE61, TPS-TEC, JT Chip, JT 200R4, Vigilante 2800 LU convertor, JT Boxed lower arms, working on girlde....
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #9 ·
my pump turns on every other brake application. Is this normal?
 

·
Registered
Joined
·
18 Posts
Smokin6, Your system sounds as though it's starting to replicate mine. You can swap out the easy stuff with a fellow TB owner, like the acumulator (ball) and then the grey switch ontop of the m/cyl. If your problem still persists after changing these, one at a time, and you've checked for bulging hoses on brake application....let me save you several frustrating hours and dollars and suggest you either purchase a replacement powermaster assembly, go to a vacuum conversion or order a m/cyl rebuild kit as the likely culprit will be the m/cyl having an internal bypass/leak. GNTTYPE.org has several great articles and troubleshooting guides to help.
HTH
Jim
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #11 ·
my powermaster assembly is still brand new. only a year old. I haven't adjusted the rear breaks. Dont know a lot about the brake system. Where do I check for bulging hoses?
 

·
Registered
Joined
·
1,293 Posts
Rubber hoses are located at ft calipers & on rear end housing"Also ck & see if there cracking"Wont cause low petal problem but might save your life!Give them a little bend if there cracked replace them.
 
1 - 12 of 12 Posts
Top