Turbo Buick Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #1 ·
hay guys,

i just installed eric's 42lb alcohol chip and i got so much white smoke coming out it would make an Orkin-man pround :D , any ideas ? i did exactly what it says i should do, diconnect the orange wire first and all that stuff but i got smoke, is that the fuel mixture? my mechanic's not in until Tomorrow :(

thanks in advance
C.E
 

·
Boost Addict?
Joined
·
2,080 Posts
Take it for a short gramps type drive around the block to let the ECM *learn* the new chip maybe? Usually takes around 15 minutes or so of driving to typically learn..
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #3 ·
ok shall do, thanks for the info.
 

·
General Useless POS
Joined
·
1,801 Posts
Hissin' Buford said:
Take it for a short gramps type drive around the block to let the ECM *learn* the new chip maybe? Usually takes around 15 minutes or so of driving to typically learn..
Sorry, but bad advice. The chip may need to learn some subtle trims, but smoke is a bad sign. DO NOT drive it like that, you very well may wash the cyls and damage the engine.

Are you sure the alky isnt spraying for some reason?

If all you did was swap chips then chances are it is a bad burn. It happens. Call/write Eric and get it straightened out before driving the car anywhere
 

·
Registered
Joined
·
2,311 Posts
sr-71 said:
hay guys,
i just installed eric's 42lb alcohol chip and i got so much white smoke coming out it would make an Orkin-man pround :D , any ideas ? i did exactly what it says i should do, diconnect the orange wire first and all that stuff but i got smoke, is that the fuel mixture? my mechanic's not in until Tomorrow
Sounds like the alky is on.
Usually, Black is rich, blue is oil, and white, water. Some times depending on concentration it's hard to tell them apart.

And like Jim mentioned bad burns do happen from time to time.
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #6 ·
well after reading turbo jim's advice i'm glad i did'nt take the car for a drive but hissin buford is right it does say "most of the learning can be done in 15 min of city driving" but i will play it safe and wait to hear from my mechanic
the car was driving great before so i know it's a chip problem, but i know i have heard nothing but good things from eric and in truth i did not take the car out for the 15 min ride it recommends i took it around the block and when i saw the smoke coming out i panic'ed. I installed back the chip that it had, i'll wait till morning and take it to my mechanic just to be safe, :(
it's just scary to see white smoke coming out of the car.

thanks for the advice guys :cheers:
C.
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #7 ·
well just giot off the phone with my mechanic and it's bad news :( , my turbo is what's throwing the white smoke out, it actually makes sence now cause last week the car felt as if it was being held back, but we could'nt figure it out, we thought the tranny was slipping ( i did'nt check the turbo for shaft play ) and my car did spin a rod a couple of weeks ago, i was told then i was lucky, cause most of the times all that metal ends up screwing up the turbo, all that and the fact that the car has over 129k miles i guess did it in :violin:

I really did'nt think it was the chip, and coming from eric, who's reputation is Impeccable i knew there was more to it than a chip. So i guess it's time to find a replacement.Thanks for all the advice guys, beers on me :cheers:
 

·
Boost Sux my Wallet
Joined
·
1,297 Posts
sorry to hear about the turbo.
Some peace though mine (stocker) started weeping a little oil into intake track at 127k.
It was not like u are saying but i was having to clean out the IC twice a year.

When you get the new turbo get the PTE turbo saver and you will not have the problem again with contamination.

I push the GT series stuff...do u have a turbo in mind yet???
 

·
Registered
Joined
·
1,208 Posts
Discussion Starter · #9 ·
well i just got a stock one for now, i'm building a stage motor and in about a month i'll have to order a pt-72 or something so just a stock replacement for now. but you were right mine hit 129k before it went :yup: , now i'm having tranny trouble AGAIN! :rant: , i've had this tranny repaired 2 times already and i just repaired it a couple of months ago. :dunno:
 
1 - 9 of 9 Posts
Top