blower fan not working on HIGH speed only? - TurboBuicks.com
 
TurboBuicks.com  
Go Back   TurboBuicks.com > Technical Forums > Buick V6 Turbo Tech

TurboBuicks.com is the premier Buick Regal Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-27-2010, 05:41 PM   #1 (permalink)
proheader
Registered User
 
Join Date: Jun 2009
Location: ne
Posts: 85
blower fan not working on HIGH speed only?

Hey gents, put in the new heater core today and went to try it out. Then we figured out the high speed on the fan will not work. It does work on all the other speeds. So, jump into tech mode and diagnosis that it would be the resistor for the fan speed relay.

Well, got a brand new A/C delco and installed it only to find out that it did not fix it. For years this has always been the problem when the fan works in all speeds but high but this time, it was not.....

any place to get a wiring diagram or any suggestions???

Proheader

hope you all had a Merry Christmas and looking to a GREAT NEW YEAR!!!!

felt good to take a spin today....cant wait until Thursday here...55 degrees!!!
proheader is offline   Reply With Quote
Old 12-27-2010, 09:02 PM   #2 (permalink)
salvageV6
Registered User
 
salvageV6's Avatar
 
Join Date: Sep 2000
Location: Connecticut, USA
Posts: 6,966
Lightbulb

Find this connector in the harness that goes down near the antenna on the passenger rear of the car left of the blower motor.

In the harness is a big fat wire that is always live and feeds the high speed relay power side to provide full voltage on High Speed.

Sometimes wiggling the connector and cleaning/reseating it fixes the problem for years.

If it looks melted or cooked cut the wiring and splice the two fat red ones together or repair with a new connector both sides if you want to be all original but it probably will burn again.

salvageV6 is offline   Reply With Quote
Old 12-27-2010, 11:14 PM   #3 (permalink)
proheader
Registered User
 
Join Date: Jun 2009
Location: ne
Posts: 85
thanks for the advise. I will run down this wire tomorrow and see what I find....

thanks

Proheader
proheader is offline   Reply With Quote
Old 02-22-2011, 03:59 AM   #4 (permalink)
626gn
Registered User
 
Join Date: Mar 2009
Posts: 20
Another component to check is the ac fan blower relay. Sometimes tapping the relay with a screwdriver will switch it on. I had the same problem with only the high setting not working.
626gn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Similar Threads
Thread Thread Starter Forum Replies Last Post
Blower fan switch Dale,G Buick V6 Turbo Tech 4 06-06-2006 07:04 PM
Heater blower not working Jake Buick V6 Turbo Tech 22 01-17-2005 11:28 PM
Fan switch only has one speed that works dr_grndntl Buick V6 Turbo Tech 7 02-17-2004 07:58 AM
fan not working shady Buick V6 Turbo Tech 1 09-10-2003 10:39 PM
How to check the high speed fan? Chris Taylor Buick V6 Turbo Tech 9 07-21-2002 09:43 PM


All times are GMT -5. The time now is 03:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Optimization by vBSEO 3.0.0